This project has moved and is read-only. For the latest updates, please go here.

Slow Bandwidth Connection

May 26, 2013 at 10:17 AM
Edited May 26, 2013 at 10:26 AM
Hi , Can helo me how can i increase my HTTP TCP Speed ?

it so slow .

My Result with VPN :
http://www.speedtest.net/result/2732352073.png
http://www.speedtest.net/result/2732355112.png
http://www.speedtest.net/result/2732358432.png

here is Same server without VPN :
http://www.speedtest.net/result/2732359415.png
http://www.speedtest.net/result/2732360141.png
http://www.speedtest.net/result/2732361840.png

Also when i try Download or test , my Ping Time (google.com) increase from 200ms to 1200ms and it seems my bandwidth is full but i just download maximum 50Kb/s without vpn my download speed is 700Kb/s
May 26, 2013 at 2:50 PM
Hi
Which protocol you using, are you sure you connect with HTTP-Tunnel not TCP?
Please send me your barba log file.
Regards
May 26, 2013 at 3:00 PM
yes here is log file :

Barba Client Started...
Version: 7.0
FilterDriver: WinDivert
Ready!
New ServerName\HTTP-Retunnel! Server: 199.x.x.x, Protocol: HTTP-Tunnel:80,8080, ConnectionID: 1.
May 26, 2013 at 4:45 PM
Hi,
It is really good case, and should not be happen. With such connection you should get atleast 2MB~3MB speed with HTTP-Tunnel
  1. Please set LogLevel to 2 and let me see the result.
  2. Send me yout HTTP config.ini
  3. Share Speedtest from your server too (in server box).
Sorry for ask these but I encounter many experts that just forget to check some basic check.
Waiting for you. Let find the issue.
Regards
May 26, 2013 at 5:36 PM
Hi ,
  1. Log level set to 2 : http://pastebin.com/P2icSPmw
  2. Http-Retunnel.ini http://pastebin.com/nVfnUnj1
  3. Speed Test From Server http://speedtest.net/result/2732969579.png
Thanks and waiting ...
May 26, 2013 at 5:54 PM
Thank you for introduce pastebin.com site to me. I wonder, all things look good. Let go further
  1. Is BarbaTunnel start retrying after while?
  2. Please set MaxUserConnections to 20 in both side.
  3. Please remove port 8080 from client side, let it just work on port 80
  4. Now restart BarbaTunnel in both side and share speedtest.net 2 time with and without VPN with same server in US.
Let I know the result.
I should also add LogIP=0|1 options to BarbaTunnels too, it will be very helpful.
May 26, 2013 at 8:21 PM
Edited May 26, 2013 at 8:21 PM
BarbaCoder wrote:
Thank you for introduce pastebin.com site to me. I wonder, all things look good. Let go further
  1. Is BarbaTunnel start retrying after while?
  2. Please set MaxUserConnections to 20 in both side.
  3. Please remove port 8080 from client side, let it just work on port 80
  4. Now restart BarbaTunnel in both side and share speedtest.net 2 time with and without VPN with same server in US.
Let I know the result.
I should also add LogIP=0|1 options to BarbaTunnels too, it will be very helpful.
Thank you , and you welcome .

is it possible my Provider limited all Tunnel bandwidth Traffic to 512kb? cause when i change it to another Provider it seems work well ...

is there trick to Make hide this tunnel from my Provider or change something like port and etc for my Provider to dont recognize it as Tunnel Packet and not shape it ?
May 26, 2013 at 8:45 PM
Hi
Did you do the stuff I request you? What is the result?
is there trick to Make hide this tunnel from my Provider or change something like port and etc for my Provider to dont recognize it as Tunnel Packet and not shape it ?
What you mean? If not What BarbaTunnel doing! BarbaTunnel just doing this.
Regards
May 27, 2013 at 6:31 AM
BarbaCoder wrote:
Hi
Did you do the stuff I request you? What is the result?
is there trick to Make hide this tunnel from my Provider or change something like port and etc for my Provider to dont recognize it as Tunnel Packet and not shape it ?
What you mean? If not What BarbaTunnel doing! BarbaTunnel just doing this.
Regards
Hi ,
i Waiting to back my bad Provider and test them , then Share result .

Thanks .
May 28, 2013 at 5:23 AM
BarbaCoder wrote:
Thank you for introduce pastebin.com site to me. I wonder, all things look good. Let go further
  1. Is BarbaTunnel start retrying after while?
  2. Please set MaxUserConnections to 20 in both side.
  3. Please remove port 8080 from client side, let it just work on port 80
  4. Now restart BarbaTunnel in both side and share speedtest.net 2 time with and without VPN with same server in US.
Let I know the result.
I should also add LogIP=0|1 options to BarbaTunnels too, it will be very helpful.
Hi ,

i Did steps .
My Speed test result with VPN :

http://www.speedtest.net/result/2735921788.png
http://www.speedtest.net/result/2735923168.png

Without VPN :

http://www.speedtest.net/result/2735923980.png
http://www.speedtest.net/result/2735925680.png
May 28, 2013 at 7:14 AM
So you connect:
  1. Only Port 80
  2. Set 20 connection
  3. Set HttpRequestMode to empty so it will be normal mode
  4. Set Log Level less than 3. Log 3 you be used for debugging and will reduce speed specially in server
  5. BarbaTunnel with Log Level 2 does not reconnecting periodically.
  6. You are using version 7.0
the second result is going to be acceptable for a http tunnel (or any tcp tunnel) but still little slower than i expected. all tcp tunnel should have near 30 till 40 percent overhead while in your case it look near 60%. Also you should know that tcp tunneling performance depends to Speed Curve Diagram too. I mean the diagram that speedtest.net draw. In bad ISP service the speed is burst up and down but the avarage is high that not suitable for tcp or http tunneling.
http://www.speedtest.net/result/2735923168.png

Now if possible set HttpRequestMode=bombard, it should be even little slower but depend your ISP it may increase your connection speed.
Currently I don't have more idea about HTTP Tunnel, In Version 7.0 I implement all of my idea about HTTP-Tunneling.
Regards
May 28, 2013 at 1:43 PM
Hi Friends,

Related to number 1. Only Port 80
If you have IIS on your server and your server has multi IP address, you can assign some IPs for IIS and use one of them for BarbaTunnel, in normal state IIS uses all IP of add network adapters, so you have to force IIS to use just some IP address, you can do this by this commands:

1) Added or make sure your machine has two ip's
2) Open a command prompt
3) Type netsh
4) Type http
5) Type show iplisten. It should be blank
6) Type add iplisten ipaddress=192.168.0.90 {This is the IP address that you want to use in IIS }
You should get IP address successfully added
7) Type show iplisten again
It should show 192.168.0.90 in the list
8) Type exit to get out of netsh
9) Type type netstat -an. See if you notice 192.168.0.90:80 in the list. If you see 0.0.0.0:80, do an iisreset
May 28, 2013 at 1:50 PM
Also here is another document about configuring port 80 on server
Configuring HTTP-Tunnel on port 80
Cheers