This project has moved. For the latest updates, please go here.

losing connection every 3 or 4 minutes

Mar 26, 2013 at 1:12 PM
I appreciate your effort for providing these kind of softwares in the long combat with the dictatorial systems
I use barba with win7(client) and win2008(server) as a proxy I use proxifier(client side) and ccproxy(server side)
everything seems to be ok and I bypass many filtered sites the only problem is losing connection every 3 or 4 minutes I have to stop and start barba in server and client in order to get connected
any kind and prompt help would be appreciated
thanks
Coordinator
Mar 26, 2013 at 3:59 PM
Hi
Barbatunnel created for school firewall not country firewall.
By the way please send me the log of barbatunel in verbose mode without restarting it.
Regards
Mar 26, 2013 at 7:26 PM
Hi dear barbacoder
this is server side log after disconnecting:
Barba Server Started...
Version: 6.4
FilterDriver: WinpkFilter
Adapter: Local Area Connection
HttpHost: TID: 17e0, Listening to TCP 207.182.143.61:80.
Ready!
HttpHost: TID: 15b0, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 15b0, Waiting for HTTP request.
New ServerName\HTTP-Retunnel! 188.159.210.153 - HTTP-Tunnel:80, VirtualIP: 10.207.0.1, ConnectionID: 1.
HttpHost: TID: 5d4, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 5d4, Waiting for HTTP request.
BarbaCourier: TID: a3c, SessionId: b0ced97d, HTTP GET connection added. Connections Count: 1.
BarbaCourier: TID: a3c, SessionId: b0ced97d, Sending fake GET reply! File: random350x350.jpg (14242 KB).
BarbaCourier: TID: a3c, SessionId: b0ced97d, Sending fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: a3c, SessionId: b0ced97d, HTTP connection is ready to send the actual data.
HttpHost: TID: 15b0, HTTP GET connection added to courier. SessionId: b0ced97d.
HttpHost: TID: 5d4, HTTP GET connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 166c, SessionId: b0ced97d, HTTP GET connection added. Connections Count: 2.
BarbaCourier: TID: 166c, SessionId: b0ced97d, Sending fake GET reply! File: random350x350.jpg (12388 KB).
BarbaCourier: TID: 166c, SessionId: b0ced97d, Sending fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: 166c, SessionId: b0ced97d, HTTP connection is ready to send the actual data.
HttpHost: TID: 10f8, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 10f8, Waiting for HTTP request.
HttpHost: TID: 10f8, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 1228, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 1.
BarbaCourier: TID: 1228, SessionId: b0ced97d, Downloading file 10739 KB.
BarbaCourier: TID: 1228, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
HttpHost: TID: 12b8, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 12b8, Waiting for HTTP request.
HttpHost: TID: 13b4, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 13b4, Waiting for HTTP request.
HttpHost: TID: 1674, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 1674, Waiting for HTTP request.
BarbaCourier: TID: 1228, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
HttpHost: TID: 13b4, HTTP GET connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 1330, SessionId: b0ced97d, HTTP GET connection added. Connections Count: 3.
BarbaCourier: TID: 1330, SessionId: b0ced97d, Sending fake GET reply! File: random350x350.jpg (12185 KB).
BarbaCourier: TID: 1330, SessionId: b0ced97d, Sending fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: 1330, SessionId: b0ced97d, HTTP connection is ready to send the actual data.
HttpHost: TID: fc4, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: fc4, Waiting for HTTP request.
HttpHost: TID: 1704, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 1704, Waiting for HTTP request.
HttpHost: TID: 900, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 900, Waiting for HTTP request.
HttpHost: TID: b5c, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: b5c, Waiting for HTTP request.
HttpHost: TID: fc4, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 11bc, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 2.
BarbaCourier: TID: 11bc, SessionId: b0ced97d, Downloading file 12150 KB.
BarbaCourier: TID: 11bc, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
HttpHost: TID: 1674, HTTP GET connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: cc8, SessionId: b0ced97d, HTTP GET connection added. Connections Count: 4.
BarbaCourier: TID: cc8, SessionId: b0ced97d, Sending fake GET reply! File: random350x350.jpg (10470 KB).
BarbaCourier: TID: cc8, SessionId: b0ced97d, Sending fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: cc8, SessionId: b0ced97d, HTTP connection is ready to send the actual data.
HttpHost: TID: 12b8, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: f40, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 3.
BarbaCourier: TID: f40, SessionId: b0ced97d, Downloading file 8468 KB.
BarbaCourier: TID: f40, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: f40, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
HttpHost: TID: 1704, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 1250, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 4.
BarbaCourier: TID: 1250, SessionId: b0ced97d, Downloading file 12741 KB.
BarbaCourier: TID: 1250, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
HttpHost: TID: b5c, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 16c4, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 5.
BarbaCourier: TID: 16c4, SessionId: b0ced97d, Downloading file 8885 KB.
BarbaCourier: TID: 16c4, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: 11bc, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
HttpHost: TID: 900, HTTP GET connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: b08, SessionId: b0ced97d, HTTP GET connection added. Connections Count: 5.
BarbaCourier: TID: b08, SessionId: b0ced97d, Sending fake GET reply! File: random350x350.jpg (11876 KB).
BarbaCourier: TID: b08, SessionId: b0ced97d, Sending fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: b08, SessionId: b0ced97d, HTTP connection is ready to send the actual data.
BarbaCourier: TID: 1250, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
BarbaCourier: TID: 16c4, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
BarbaCourier: TID: 1250, SessionId: b0ced97d, Error: An existing connection was forcibly closed by the remote host.
BarbaCourier: TID: 1250, SessionId: b0ced97d, HTTP POST connection removed. Connections Count: 4.
BarbaCourier: TID: 16c4, SessionId: b0ced97d, Error: An existing connection was forcibly closed by the remote host.
BarbaCourier: TID: 16c4, SessionId: b0ced97d, HTTP POST connection removed. Connections Count: 3.
BarbaCourier: TID: 1228, SessionId: b0ced97d, Error: An existing connection was forcibly closed by the remote host.
BarbaCourier: TID: 1228, SessionId: b0ced97d, HTTP POST connection removed. Connections Count: 2.
HttpHost: TID: 1544, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 1544, Waiting for HTTP request.
HttpHost: TID: 1544, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: b10, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 3.
BarbaCourier: TID: b10, SessionId: b0ced97d, Downloading file 14185 KB.
BarbaCourier: TID: b10, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: b10, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
HttpHost: TID: 1664, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 1664, Waiting for HTTP request.
HttpHost: TID: 13d8, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 13d8, Waiting for HTTP request.
HttpHost: TID: 13d8, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 12cc, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 4.
BarbaCourier: TID: 12cc, SessionId: b0ced97d, Downloading file 13941 KB.
BarbaCourier: TID: 12cc, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: 12cc, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
HttpHost: TID: 1664, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: 1558, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 5.
BarbaCourier: TID: 1558, SessionId: b0ced97d, Downloading file 7731 KB.
BarbaCourier: TID: 1558, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
BarbaCourier: TID: 1558, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
HttpHost: TID: 1524, New incoming connection. ServerPort: 80, ClientIp: 188.159.210.153.
HttpHost: TID: 1524, Waiting for HTTP request.
BarbaCourier: TID: 11bc, SessionId: b0ced97d, Error: A blocking operation was interrupted by a call to WSACancelBlockingCall.
BarbaCourier: TID: 11bc, SessionId: b0ced97d, HTTP POST connection removed. Connections Count: 5.
BarbaCourier: TID: a30, SessionId: b0ced97d, HTTP POST connection added. Connections Count: 5.
BarbaCourier: TID: a30, SessionId: b0ced97d, Downloading file 13944 KB.
BarbaCourier: TID: a30, SessionId: b0ced97d, Waiting for incoming fake file header. HeaderSize: 2 KB.
HttpHost: TID: 1524, HTTP POST connection added to courier. SessionId: b0ced97d.
BarbaCourier: TID: a30, SessionId: b0ced97d, HTTP connection is ready to receive the actual data.
BarbaCourier: TID: f40, SessionId: b0ced97d, Error: An existing connection was forcibly closed by the remote host.
BarbaCourier: TID: f40, SessionId: b0ced97d, HTTP POST connection removed. Connections Count: 4.
BarbaCourier: TID: 1558, SessionId: b0ced97d, Error: An existing connection was forcibly closed by the remote host.
BarbaCourier: TID: 1558, SessionId: b0ced97d, HTTP POST connection removed. Connections Count: 3.
BarbaCourier: TID: b10, SessionId: b0ced97d, Error: An existing conne
Coordinator
Mar 26, 2013 at 10:07 PM
Hi
I think your server connection count or pair key does not match to client.
Currently I have not more idea.
Let me know if you solve this issue.
Regards
Mar 28, 2013 at 6:42 AM
BarbaCoder wrote:
Hi
I think your server connection count or pair key does not match to client.
Currently I have not more idea.
Let me know if you solve this issue.
Regards
hi
I checked the keys are the same but how can I check the count?
thx
Coordinator
Mar 28, 2013 at 11:20 AM
Hi
I mean MaxUserConnections in client side of following document much less than MaxUserConnections of server side.
http://barbatunnel.codeplex.com/wikipage?title=config.ini&referringTitle=Documentation
Regards
Mar 29, 2013 at 4:27 AM
Hi Dear barbacoder

don't u have any suggestion to make the connection more stable?(it disconnects repeatedly)

thanks
Coordinator
Mar 30, 2013 at 2:19 AM
Edited Mar 30, 2013 at 2:46 AM
Hi,
As I check your client ip it look you trying to connect vpn from iran. Many users get success from your country so you should get success too.

Let me Know (All) of following questions
  1. The enterprise firewall you are behind of. Iran?
  2. Share me speed test speedtest.net result to a US point without vpn connection.
  3. Did you increase server MaxUserConnections?
Mar 30, 2013 at 4:21 AM
BarbaCoder wrote:
Hi,
As I check your client ip it look you trying to connect vpn from iran. Many users get success from your country so you should get success too.

Let me Know (All) of following questions
  1. The enterprise firewall you are behind of. Iran?
  2. Share me speed test speedtest.net result to a US point without vpn connection.
  3. Did you increase server MaxUserConnections?
Hi

I am behind iran firewall,my download speed is 3.29 mbps but it cant calculate my upload speed as it returns error,I connected with l2tp but with out internet access with pptp it returns 807 error I cant totally connect with pptp,
I could get connected with proxy but it disconnects after some minutes and after that I try many times to connect again but it is useless
I haven't increased MaxUserConnections yet ,give me the exact number for server and client plz.
many regards
Coordinator
Mar 30, 2013 at 4:31 AM
I think you are using some kind of wireless network with weak upload speed, please select another US node in speedtest.net, if your upload speed is less than 128 kbit/sec you could not use barbatunnel. Even any VPN would be so slow.
It is no matter how much your download speed is, you need at least 128kbit/sec upload speed.
Regards
Mar 30, 2013 at 4:52 AM
Hello again

just to test it I set MaxUserConnections in the servet to 20 but kept the client side unchanged It did me no good and nothing changed
still I get connected for the first time and after sometimes I lose connection and all next attempts to get connected again are in vain(the client's barba status turns into started rapidly but the server side's barba status remains on idle and dosnt alter to started)

many thanks
Mar 30, 2013 at 4:58 AM
Hi

my upload speed is 0.52 mbps which is more than 128kbps that u mentioned

thx
Coordinator
Mar 30, 2013 at 5:01 AM
alimomen wrote:
Hello again

just to test it I set MaxUserConnections in the servet to 20 but kept the client side unchanged It did me no good and nothing changed
still I get connected for the first time and after sometimes I lose connection and all next attempts to get connected again are in vain(the client's barba status turns into started rapidly but the server side's barba status remains on idle and dosnt alter to started)

many thanks
Just set both them 5.
Coordinator
Mar 30, 2013 at 5:08 AM
alimomen wrote:
Hello again

just to test it I set MaxUserConnections in the servet to 20 but kept the client side unchanged It did me no good and nothing changed
still I get connected for the first time and after sometimes I lose connection and all next attempts to get connected again are in vain(the client's barba status turns into started rapidly but the server side's barba status remains on idle and dosnt alter to started)

many thanks
You should not get such error:
BarbaCourier: TID: 11bc, SessionId: b0ced97d, Error: A blocking operation was interrupted by a call to

Sorry currently I have not more idea.
Mar 30, 2013 at 5:22 AM
Dear Barbacoder

I think if u agree it would be more efficient to give u my server's password in order to check all my settings in barba ,RRAS and proxy
so sorry to put u into so much trouble
thx
Mar 30, 2013 at 6:37 AM
would u plz give me your email address to send u my vps account?
Coordinator
Mar 30, 2013 at 1:27 PM
Dear alimomen
Unfortunately My security policy does not let me to connect to a server.
One of other user have same issue, would you take speed test from your server and let me know the result?
Regards
Coordinator
Mar 30, 2013 at 2:48 PM
Hi
I got some report that many DDOS attack recently on many servers in the world (even one of my server), maybe your server or your hosting provider is one of them.
Please check speedtest.net in your server and share me the result.
Make sure you select a sever in another state of your server when you get test by speedtest.net, otherwise you may just get result from your own server hosting test. for example if your server exists in California you should select a node in Virginia.
Regards
Mar 30, 2013 at 6:51 PM
I chose a node in Columbia ping:353ms download speed:0.54 Mbps upload speed:0.32Mbps
Coordinator
Mar 30, 2013 at 8:05 PM
Did you test it via RDP? this speed is too slow for a server, just 512Kbit/sec for a server is not acceptable! When you download 10MB, your server will download 10MB from internet then it send that 10MB to your client, so it take double traffic (20MB), imagine how it could be possible with upload speed:256KB/s!
A very slow server should atleast have 10MB/s (10,000KB/s) speed.
I think this is the reason why your connection dropped. see following article:
http://securitywatch.pcmag.com/none/309844-is-the-spamhaus-ddos-attack-over

Anyway you could not use such server for VPN server even personal VPN server, you should contact your server hosting and report the speed issue, if they told you it is normal for your server you should change your server. one of my server got same issue, its speed became 256Kbit just from 2 days ago, when I report it to my server support they fix it and it become 70MB/s now. I wish you have same issue.
Let me know if you solve the issue.
Regards
Mar 31, 2013 at 11:07 AM
Hi
I chose a node in Chicago the recent test shows download speed:9.59 mbps and upload speed:17.68,

aren't they sufficient?
thx
Mar 31, 2013 at 11:25 AM
BarbaCoder wrote:
Dear alimomen
Unfortunately My security policy does not let me to connect to a server.
One of other user have same issue, would you take speed test from your server and let me know the result?
Regards
would u plz clarify what may be the harms of connecting to my server due to your security policy?
Coordinator
Mar 31, 2013 at 11:28 AM
Ya, it is enough, try HTTP-Tunnel again, Just check for "Error: An existing connection was forcibly closed by the remote host", If you get it such error again. don't waste your time to check other method, HTTP-Tunnel should work in port 80. Try install an IIS and check is it possible to download a simple 10MB zip file? actually barbatunnel create same connection and I wonder why you get such error.
What is your ISP, ask other users and check is anyone got success with that ISP, maybe someone reply you.
Currently I have not more idea
Good Luck
Coordinator
Mar 31, 2013 at 11:32 AM
alimomen wrote:
BarbaCoder wrote:
Dear alimomen
Unfortunately My security policy does not let me to connect to a server.
One of other user have same issue, would you take speed test from your server and let me know the result?
Regards
would u plz clarify what may be the harms of connecting to my server due to your security policy?
  1. It will be useless to connect to your server , because I am not behind of your enterprise firewall, even simple VPN without barbatunnel may work,
  2. When you connect to a server your IP address will be revealed in server and routers in the middle and it is most dangerous job.
    Regards
Apr 1, 2013 at 4:02 AM
Hello
I think my problem has nothing to do with ISP or server because I used to connect with the same ISP and server .and it was very stable and with a good download speed
recently I have this problem that it gets disconnected and try it again is almost impossible it seems to be maybe some kind of conflict or misconfiguration. I meant to connect to my server to check the settings not to bypass the firewall
would u suggest some kind of similar tunneling ?
I was satisfied with barba regarding the speed
regards
Apr 1, 2013 at 4:08 AM
Edited Apr 1, 2013 at 4:28 AM
and I think if I manage to connect with VPN the problem may disappear because I have tried barba just with proxy .but the error 807 dosnt let me do this
and the other point is in all three HTTP-Retunnel.ini,SSTP-Redirect.ini and UDP-Retunnel.ini files I have inserted my server ip address and Enable=1 ,when for example I am using http ,isn't necessary to somehow disable udp or sstp in configurations?
many thanks
Coordinator
Apr 1, 2013 at 7:11 AM
alimomen wrote:
and I think if I manage to connect with VPN the problem may disappear because I have tried barba just with proxy .but the error 807 dosnt let me do this
and the other point is in all three HTTP-Retunnel.ini,SSTP-Redirect.ini and UDP-Retunnel.ini files I have inserted my server ip address and Enable=1 ,when for example I am using http ,isn't necessary to somehow disable udp or sstp in configurations?
many thanks
No it is not necessary to disable them. Leave other settings, the HTTP-Tunnel should not report: "Error: An existing connection was forcibly closed by the remote host".
BarbaTunnel not used widely across the world yet, something break the standard http connection, maybe you country detect HTTP request from BarbaTunnel and end it (just maybe, I don't think so they focus to barbatunnel yet due the download rate of barbatunnel),

anyway in this case If you understand networking try do following stuff (Note: it is so advanced configuration)
  1. Change its request pattern see "Template" folder and change HTTP request templates, (do not change variables { }"
  2. Change Key in config.ini in both side, make sure you have a key
  3. Set FakePacketMinSize to 400 or 1200 in both side (Warning: Do it just for test broken connection, it will decrease connection dramatically).
  4. Set RequestDataKeyName of config.ini in both side in both side to random such as BlaBla123. both side should be same.
  5. Set FakeFileTypes of config.ini to zip only.
  6. Restart BarbaTunnel in both side.
Regards
Apr 1, 2013 at 7:30 AM
Dear Barbacoder

I just changed the port to only 8080,the connection lasts longer in comparison with 80 but suddenly in client side it shows this error:
An established connection was aborted by the software in your host machine
seems like another program interferes and this leads to disconnection
Coordinator
Apr 1, 2013 at 7:42 AM
check barbatunnel 5.3 at server side with windivert and uninstall winpkfilter in both side.
the only app that may be interferes is winpkfilter, otherwise just enterprise firewall can break it because BarbaTunnel bind the port and establish tcp connection and could not be interferes by other applications or services.
Apr 1, 2013 at 8:23 AM
BarbaCoder wrote:
check barbatunnel 5.3 at server side with windivert and uninstall winpkfilter in both side.
the only app that may be interferes is winpkfilter, otherwise just enterprise firewall can break it because BarbaTunnel bind the port and establish tcp connection and could not be interferes by other applications or services.
Hi barbacoder
many thanks for your great patience .I tried to install windivert on server but as my server is win 2008 enterprise it is incompatible with windivert(as u mentioned the windivert issue with non R2 servers it gives error 110 I think) I think the only option is changing the server to R2
Coordinator
Apr 1, 2013 at 8:33 AM
alimomen wrote:
BarbaCoder wrote:
check barbatunnel 5.3 at server side with windivert and uninstall winpkfilter in both side.
the only app that may be interferes is winpkfilter, otherwise just enterprise firewall can break it because BarbaTunnel bind the port and establish tcp connection and could not be interferes by other applications or services.
Hi barbacoder
many thanks for your great patience .I tried to install windivert on server but as my server is win 2008 enterprise it is incompatible with windivert(as u mentioned the windivert issue with non R2 servers it gives error 110 I think) I think the only option is changing the server to R2
Barbatunnel 5.3 using old version of windivert and can be used for non r2.

Would you tell me what is your ISP. Is it some kind of wireless or cell network?
Apr 1, 2013 at 9:03 AM
I use wireless at home but very close to the router and my ISP is cell network.
as I noticed the disconnection procedure on client just before losing connection the message:Error: Invalid packet received and dropped!
is shown but still the connection is not dead and after sometimes(nearly 1 or 2 min) the message:An established connection was aborted by the software in your host machine
and then both barba on server and client try to get connected which in very rare cases is successful and restarting is required
Coordinator
Apr 1, 2013 at 9:15 AM
Hi
I have list of ISPs from clients, please let me know
  1. Your ISP name.
  2. Your ISP technology (Cable, ASDL, WiMax, GPRS, 3G or LTE)
    Regards
Apr 1, 2013 at 9:49 AM
the ISP name:Neda Gostar saba
ADSL
thanks
Coordinator
Apr 1, 2013 at 12:04 PM
OK, thanks for sharing i add it to my list.
I have two suggestion:
  1. Try to test it with other ISP via your friends, if it work it mean it due to your ISP.
  2. You told you have internet access in 2 min then BarbaTunnel Starting retrying, in this case try this: set MaxUserConnections to 40 in both side and restart barbatunnel in both then connect your VPN, after 2 min you should start get huge retrying as you said but you have 30 connections now, wait 10 min and do not restart BarabTunnel, let it retry and retry, in meanwhile you should have always active connection to send and receive packets even BarbaTunnel always in reconnecting some connections.
Let me know the result
Regards
Apr 1, 2013 at 8:01 PM
Edited Apr 2, 2013 at 5:23 AM
Hi
barba tunnel 5.3 cant be installed on server 2008 enterprise (windivert error 110 like before)
the second suggestion didn't work either ,the maximum value for MaxUserConnections is 20 (cant be set to 40)
I set it to 20 but after sometimes(more than past) it disconnected and took a long time to connect in the first time
I used barba without any problem in the first days the disconnecting issue began afterwards so as I mentioned ISP and server cant be involved
so disappointing

thx
Apr 2, 2013 at 5:18 AM
sorry how to change request pattern in template?i didn't get it
Apr 2, 2013 at 5:21 AM
BarbaCoder wrote:
  1. Change its request pattern see "Template" folder and change HTTP request templates, (do not change variables { }"
sorry how to do it?i didn't get your point
Coordinator
Apr 2, 2013 at 7:37 AM
alimomen wrote:
BarbaCoder wrote:
  1. Change its request pattern see "Template" folder and change HTTP request templates, (do not change variables { }"
sorry how to do it?i didn't get your point
It is very advanced topic.
Unfortunately not have more idea.
Sorry for this inconvenience.
Regards
Coordinator
Apr 3, 2013 at 6:51 AM
Hi
I have an idea!
Would you set KeepAliveInterval in HTTP-Retunnel.ini of client to 400 and let me know the result?
Cheers
Apr 5, 2013 at 5:39 AM
BarbaCoder wrote:
Hi
I have an idea!
Would you set KeepAliveInterval in HTTP-Retunnel.ini of client to 400 and let me know the result?
Cheers
Hi
sorry my server is down and I don't have any access to it as soon as I can get connected I will do this and let u know the result
Apr 8, 2013 at 12:16 PM
BarbaCoder wrote:
Hi
I have an idea!
Would you set KeepAliveInterval in HTTP-Retunnel.ini of client to 400 and let me know the result?
Cheers
hi barba
this setting failed too,still confused about the reason
thanks
Apr 8, 2013 at 2:12 PM
hi barba . i have problem with client side.

when runing barba . get connection lost . and
this messages.
how can fix this. connected via wireless . and isp : Datak
Error: Invalid packet received and dropped!
BarbaTunnel Stopping.
BarbaTunnel Stopped.
Coordinator
Apr 8, 2013 at 4:32 PM
MLunatic wrote:
hi barba . i have problem with client side.

when runing barba . get connection lost . and
this messages.
how can fix this. connected via wireless . and isp : Datak
Error: Invalid packet received and dropped!
BarbaTunnel Stopping.
BarbaTunnel Stopped.
Hi,
Make sure you have latest version in both side and have same FilterDriver in both side.
I got reported this from some rare users too but unfortunetely does not know the reasons.
Regards
Apr 8, 2013 at 6:51 PM
same version . cliend and server side .

and filterdrive too.
its my first problem . and second one .
when person connected with pptp/l2tp no page cant opend . seems internet lost . must be disconnect .
Coordinator
Apr 8, 2013 at 7:01 PM
MLunatic wrote:
same version . cliend and server side .

and filterdrive too.
its my first problem . and second one .
when person connected with pptp/l2tp no page cant opend . seems internet lost . must be disconnect .
How I say about second problem when you couldn't establish the connection?!
By the way if you establish connection from your client and server they try to ping your server via its VPN ip (not server ip), I mean ping your server via tunnel with VPN assigned IP. for example: ping 192.168.x.x -L 1400
If it is ok and you get fast reply then you should have issue in your VPN configuration and it is not relate to BarbaTunnel, perhaps NAT or routing problem, it mean you connect to your server but could not steal internet traffic.
Check https://barbatunnel.codeplex.com/documentation and read Other Documents to configure your server properly.
Regards
Coordinator
Apr 13, 2013 at 12:28 AM
Hi,
I detect the issue, it look my HTTP does not compatible with some proxy servers. Temporary you can make it HTTP-Tunnel to simple TCP-Tunnel.
Of-course it may not work if simple TCP blocked but it usually happen at company level firewall not country level firewall, just go to template folder and set following text.


** HTTP-GetReplyTemplate.txt :
OK
ETag: {data}

** HTTP-GetTemplate.txt
GET
Cookie: {data}

** HTTP-PostTemplate.txt
POST
Cookie: {data}


Note: this change make your connection as simple TCP connection not HTTP connection, so if failed try to an open port other than 80 because it is not HTTP by the way. mean-while i try to add build-in TCP tunnel and maybe add feature to support http proxies.
Regards