Problem with version 6.0

Jan 1, 2013 at 1:09 PM
Edited Jan 1, 2013 at 1:15 PM

Hi

I have problem with new version (6.0)!
After installing, i get this error in Barba Monitor: "Error: Could not set packet filtering!" when i set to using WinpkFilter. By default filter driver, BarbaTunnel.exe crash! OS is Windows Server 2008 SP2 Standard.

I have another server with version 5.3 and it works (windows server 2003 run on)!

And at last, version 6.0 not running on windows 2003 (because programming with VS 2012...)

Thanks

Coordinator
Jan 16, 2013 at 4:03 PM

Hi,

I update it, please check new version 6.2

Also I strongly recommend you to use WinDivert if possible. I will not check WinpkFilter more.

Regards

Jan 23, 2013 at 5:40 AM

It doesn't work!

With default WinDivert driver i get this error:

"Barba Server Started...
Version: 6.3
FilterDriver: WinDivert
Error: Failed to open Divert device (110)!
1) Try to Install BarbaTunnel again.
2) Make sure your windows has been restarted.
3) Make sure your Windows x64 test signing is on: BCDEDIT /SET TESTSIGNING ON"

And WinpkFilter:

"Barba Server Started...
Version: 6.3
FilterDriver: WinpkFilter
Adapter: Local Area Connection
Error: Could not set packet filtering!"

 

Both Filter drivers have problem!

Coordinator
Jan 23, 2013 at 6:09 AM

Hi,

Please let know 

  1. What is you Windows version (2003, xp, 7, 8)? 3bit ot 64bit?
  2. Do you get same result with other platform?
  3. Run regedit and tell me the value of: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WinDivert1.0\ImagePath , is it point to valid path?
  4. Do you have same issue with BarbaTunnel 5.3
  5. Can you run Windows Fire Wall? WinDivert use Windows Fire Wall built in driver called Windows Filtering Platfrom (WFP) so if you could not run Windows Fire Wall, WinDivert will fail too.
  6. run install.vbs again > restart machine > let me know the result

Sorry I have no time to test it with WinpkFilter more. if you know an issue in source code just let me know.

By the way please let know your workaround and result.

Regardds

Jan 23, 2013 at 6:53 AM
Edited Jan 23, 2013 at 6:57 AM

And answers ;)
1. I wrote above, OS is Windows Server 2008 X86 SP2
2. I tested on Win 7 X86 and by WinDivert it worked but with WinpkFilter it failed
3. On Windows Server I couldn't find any path about "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WinDivert1.0" but On Windows 7 yes it is.
4. No, Barba v5.3 is working fine
5. Yes Firewall running
6. I did but nothing...

 

I test with both drivers, maybe another worked

Coordinator
Jan 23, 2013 at 7:09 AM

So the problem exists in Windows Server 2008 x86?

Currently I have not "Windows Server 2008 x86 box" but I will try to create one, 

Thanks for your report.

 

Jan 23, 2013 at 7:57 AM

Yes the problem occur in Windows 2008

Thank you

Coordinator
Jan 23, 2013 at 5:06 PM

I check it, WinDivert has this issue, I even couldn't run WinDivert sample on both Windows Server 2008 32bit & 64bit. But it run on Windows Server 2008 r2

I report it to WinDivert and I will update BarbaTunnel as soon as they fix WinDivert.

Regards