This project has moved. For the latest updates, please go here.

Configuration between work and home

May 9, 2014 at 4:41 PM
I have a configuration question regarding a scenario I'm trying to setup. I'm not 100% how Barba works.

Scenario:
I want to access the internet from work via my home server.
I have a work computer behind a proxy and firewall (filters VPN traffic).
I have a home computer behind a router.
I want to tunnel from my work computer -> to home computer -> Web.

I also want the ability to remote desktop from work into my home computer, but my work proxy/firewall won't allow it.

Client Configuration - BarbaTunnel.ini

[General]
ServerMode=0
DebugMode=
AdapterIndex=
MTUDecrement=
ConnectionTimeout=
LogLevel=3
LogAnonymously=
TimeZone=
;F?ilterDriver=WinpkFilter

[Server]
VirtualIpRange=
AutoStartDelay=1

Client Configuration - HTTP-Retunnel.ini

[General]
ServerAddress=<My Home WAN IP Address>
Enabled=1
Mode=HTTP-Tunnel
Key=1234567890ABCDEF
GrabProtocols=GRE:,TCP:1723,ESP:,UDP:1701,UDP:500,UDP:4500
TunnelPorts=80,8080
MaxUserConnections=
FakeFileTypes=jpg,zip

; None | Normal | Bombard
HttpRequestMode=

; In kilobyte
MaxTransferSize=

; In Bytes
MinPacketSize=

; In second
KeepAliveInterval=

[Server]
AllowHttpRequestNone=
AllowHttpRequestNormal=
AllowHttpRequestBombard=

Server Configuration - BarbaTunnel.ini

[General]
ServerMode=1
DebugMode=
AdapterIndex=
MTUDecrement=
ConnectionTimeout=
LogLevel=3
LogAnonymously=
TimeZone=
;F?ilterDriver=WinpkFilter

[Server]
VirtualIpRange=
AutoStartDelay=1


Server Configuration - HTTPTunnel.ini

[General]
ServerAddress=<My Home Local IP Address>
Enabled=1
Mode=HTTP-Tunnel
Key=1234567890ABCDEF
GrabProtocols=GRE:,TCP:1723,ESP:,UDP:1701,UDP:500,UDP:4500
TunnelPorts=80,8080
MaxUserConnections=
FakeFileTypes=jpg,zip

; None | Normal | Bombard
HttpRequestMode=

; In kilobyte
MaxTransferSize=

; In Bytes
MinPacketSize=

; In second
KeepAliveInterval=

[Server]
AllowHttpRequestNone=
AllowHttpRequestNormal=
AllowHttpRequestBombard=

Router

Port Forwarding ports 80, 8080, and my remote desktop port to my home server IP address.

Thanks. Jake.
Coordinator
Sep 12, 2014 at 5:10 AM
Try to establish VPN, BarbaTunnel is not standalone Tunnel