how to set up a client in win xp?

Mar 11, 2013 at 7:22 AM
hi,

I understand that winxp is going be departed soon, but it is not an option for me to use win 7/8 with the company IT policy.

I installed WinpkFilter 3.1 in my company and modified "setup/InstallAndRun.vbs"

is64=0
isxp=1

I executed "Install.vbs" then got a message box "c:\BarbaTunnel-6.3-win\bin\BararMonitor.exe is not a correct Win32 application."

Please share some experience about how to run BarbaTunnel client on WinXP successfully.

Thank you very much.
Coordinator
Mar 12, 2013 at 12:49 AM
Hi,
I just fix BarbaTunnel for Windows XP -- FOR you. In http-tunnel You can use WinDivert one side and WinpkFilter in the other side.
Please note that you could not use BarbaMonitor and BarbaService in Windows XP because .NET 4.5 could not be installed in Windows XP but they are just some UAC and UI helper, Windows XP users should run BarbaTunnel.exe manually.
I checked it and it worked for me in my Windows XP virtual Machine.
Please download version 6.4.
Cheers.
Mar 12, 2013 at 2:14 AM
hi BarbarCoder,

Thank you very much.

I executed BarbaTunnel.exe manually and so far no any error happens.

I still try to build a successful tunnel wit the outside server.

Thanks again.

Best regards.
Mar 21, 2013 at 6:31 PM
Hi,
i test it in my virtual xp but it says this :

Barba Client Started...
Version: 6.4
FilterDriver: WinpkFilter
Error: Driver not installed on this system or failed to load!
Please go to http://www.ntndis.com/w&p.php?id=7 and install WinpkFilter driver.

i install WinpkFilter into xp and restart it but it does not solved!
Coordinator
Mar 21, 2013 at 6:38 PM
hi
You sould download WinpkFilter from here:
http://www.ntndis.com/downloads/winpkflt_rtl.zip

WinpkFilter have two mode for Windows XP, check it with another mode. Actually I couldn't install previous WinpkFilter with XEN box, but I got success for VMWare boxes. Let me know what is you virtual box technology.
Regards
Mar 21, 2013 at 6:40 PM
i use vmware
i check two mode and none of them works
Coordinator
Mar 21, 2013 at 6:45 PM
Edited Mar 21, 2013 at 6:47 PM
Sorry, I have no more idea. I couldn't do anything when FilterDriver failed.
I tried windows XP Service Pack 2 and it work.
Maybe you have some other Network Adapter, try changing AdapterIndex
To see the list of all available Adapters run "listadapters.exe" in WinpkFilter folder.

Regards
Mar 21, 2013 at 6:56 PM
Who are you?! you are a genius :*
I like to be somebodey like you, Know many thing about protocols and network.
It is solved. it is related to my adapterindex

Thanks