Problem with starting service on windows 2003 R2 32bit

Mar 9, 2013 at 6:39 PM
hi
thank you for your greate program
i have installed the barbatunnel with the file install and run in the discussions
i set
[General]
ServerMode=1
DebugMode=0
VerboseMode=1
AdapterIndex=0
MTUDecrement=
ConnectionTimeout=15
MaxLogFileSize=
FilterDriver=WinpkFilter

[Server]
ConfigFileName=
VirtualIpRange=10.207.0.0-10.207.255.255.
AutoStartDelay=3

and i install winpkfilter in the package
i do not have that registery key in my registery setting
when i want to start the service
it doesnt start

Barba Server Started...
Version: 5.3
FilterDriver: WinpkFilter
Adapter: Local Area Connection
Error: Could not set packet filtering!

in the client i have win 7 64 sp1 and it works and started


i use 5.3 version

what should i do/??? to start this???
and can i use the client with FilterDriver: WinDivert and in the server i use winpkfilter ?
can it connect to the server?
Coordinator
Mar 9, 2013 at 9:49 PM
Dear miladx12
In theory it should work with different FilterDriver, but I didn't check winpkfilter anymore and don't support it.
Regards
Coordinator
Mar 12, 2013 at 12:51 AM
Dear miladx12
I update BarbaTunnel with the recent version of winpkfilter. It work on Windows XP but I didn't check it on Windows 2003 server.
I think it should work there too, You can download version 6.4 and let me know too.
Regards
Mar 13, 2013 at 5:35 AM
Thank you for your good support
but in this version when i want to install
it gives an error
barbamonitor.exe is not a valid win32 application
Coordinator
Mar 13, 2013 at 7:12 AM
Hi,
You could not use BarbaMonitor and BarbaService in Windows XP & 2003 because .NET 4.5 could not be installed in these platforms but they are just some UAC and UI helper, Windows XP & 2003 users should run BarbaTunnel.exe manually.
I checked it with windows XP and it worked for me in my Windows XP virtual Machine. I didn't check it on Windows 2003.
Just go to bin folder and run BarbaTunnel.exe, let me know the result.
Regards
Mar 13, 2013 at 7:26 AM
i did it

Barba Client Started...
Version: 6.4
FilterDriver: WinpkFilter
Error: Driver not installed on this system or failed to load!
Please go to http://www.ntndis.com/w&p.php?id=7 and install WinpkFilter driver.
Mar 13, 2013 at 7:48 AM
i finaly connected
and it started after i re install the winpkfilter
but still i can not connect via pptp or other conenction
the report
BarbaCourier: TID: 1644, SessionId: c8c703dd, Creating HTTP POST connection. ServerPort: 8000.
BarbaCourier: TID: c58, SessionId: c8c703dd, Creating HTTP GET connection. ServerPort: 8000.
BarbaCourier: TID: bd0, SessionId: c8c703dd, Creating HTTP GET connection. ServerPort: 8000.
BarbaCourier: TID: 1140, SessionId: c8c703dd, Creating HTTP POST connection. ServerPort: 8000.
BarbaCourier: TID: 428, SessionId: c8c703dd, Creating HTTP GET connection. ServerPort: 8000.
BarbaCourier: TID: 1abc, SessionId: c8c703dd, Creating HTTP GET connection. ServerPort: 8000.
BarbaCourier: TID: 64c, SessionId: c8c703dd, Creating HTTP POST connection. ServerPort: 8000.
BarbaCourier: TID: 624, SessionId: c8c703dd, Creating HTTP GET connection. ServerPort: 8000.
BarbaCourier: TID: 1b34, SessionId: c8c703dd, Creating HTTP POST connection. ServerPort: 8000.
BarbaCourier: TID: 1a20, SessionId: c8c703dd, Creating HTTP POST connection. ServerPort: 8000.
BarbaCourier: TID: 1644, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 1644, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: c58, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: c58, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: bd0, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: bd0, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 1140, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 1140, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 428, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 428, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 1b34, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 1b34, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 1a20, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 1a20, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 1abc, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 1abc, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 64c, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 64c, SessionId: c8c703dd, Retrying in 10 second...
BarbaCourier: TID: 624, SessionId: c8c703dd, Error: No connection could be made because the target machine actively refused it.
BarbaCourier: TID: 624, SessionId: c8c703dd, Retrying in 10 second...
Mar 13, 2013 at 7:49 AM
i can give you a remote session
Mar 13, 2013 at 7:58 AM
i have connecteeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeed
Coordinator
Mar 13, 2013 at 9:56 AM
Congratulation.
Perhaps in your first attempt a firewall block port 8000.
I recommend you to establish connection port 80 so simulate http request 100%
Cheers
Mar 13, 2013 at 11:01 AM
Edited Mar 13, 2013 at 11:01 AM
Hey BarbaCoder
Just a problem with v6.4. It doesn't start UDP-Tunnel but HTTP-Tunnel is working well! I'm on Windows 2003 R2 x86 and using WinpkFilter (indeed)

Please check it
Coordinator
Mar 13, 2013 at 11:28 AM
Hi
I am very busy with my other projects now and may check it in another time, but please make sure both side using same FilterDriver with same MTU when using non HTTP mode. Also please attention some strict Firewalls or ISP may drop big UDP packet so make sure you have clean connection then try to using UDP.
I usually check UDP in my own private network , anyway if UDP tunnel work its should have much better performance than HTTP tunnel. So you need to check it with a local network first.

Regards
Mar 13, 2013 at 12:14 PM
Dear BarbaCoder,
I'm not so beginner. The problem is in server side and barbatunnel doesn't bind any port that has set in TunnelPorts. The problem is this!
Coordinator
Mar 13, 2013 at 12:26 PM
Dear sireba
Ya, BarbaTunnel does not bind any UDP port because it grab and process packet with PacketFiltering at network level not standard binding system. So if you see the list of binded ports you will not see any binding for that port, but actually BarbaTunnel should grab it before it reach to OS binding system.
By the way, when you connect to your server with UDP you should see at-least a notification from both client and server side, can you see it?
Regards
Mar 13, 2013 at 12:49 PM
Yeah, I checked again and found the problem (was with WinpkFilter), it should be updated to version 3.1

Sorry ;)
Coordinator
Mar 13, 2013 at 12:51 PM
Congratulation!
So did you connect VPN from client to server via UDP tunnel properly?
Regards
Mar 13, 2013 at 1:34 PM
Yes like a charm ;)
I like UDP because it's very faster than other methods. This is additional note; People that use windows XP and or 2003 but like to run BarbaTunnel as a service can use NSSM to do it. It's so simple but powerful tool

Thanks BarbaCoder for this great project and i hope you continue supporting BarbaTunnel in the future
Mar 22, 2013 at 10:48 PM
hi barbacoder
im use win 2003 and client win7
barbatunnel 6.4 Both systems are installed
barbartuunel.ini server :
[General]
ServerMode=1
DebugMode=
VerboseMode=
AdapterIndex=
MTUDecrement=
ConnectionTimeout=
FilterDriver=WinpkFilter

[Server]
ConfigFileName=
VirtualIpRange=
AutoStartDelay=3

barbartuunel.ini win7 :
[General]
ServerMode=0
DebugMode=
VerboseMode=
AdapterIndex=
MTUDecrement=
ConnectionTimeout=
FilterDriver=WinpkFilter

[Server]
ConfigFileName=
VirtualIpRange=
AutoStartDelay=3

HTTP-Retunnel server and win :
[General]
ServerAddress=66.187.6........
Enabled=1
Mode=HTTP-Tunnel
Key=1234567890ABCDEF
TunnelPorts=8080
GrabProtocols=GRE:*,TCP:1723,TCP:443,UDP:443,UDP:1 701,TCP:1701,UDP:500,UDP:4500
MaxUserConnections=
FakeFileTypes=jpg,zip
FakeFileMaxSize=
FakePacketMinSize=
KeepAliveInterval=
RequestDataKeyName=

pptp vpn not connect but l2tp connected also speed very low and The l2tp vpn connection is sometimes

barbartunnel log :

Barba Client Started...
Version: 6.4
FilterDriver: WinpkFilter
Adapter: Local Area Connection
Ready!
New ServerName\HTTP-Retunnel! Server: 66.187.6......., Protocol: HTTP-Tunnel:8080, ConnectionID: 1.

i use nttacplus on win 2003 for accounting aplication
radius authentication port : 1812
radius accounting port : 1813

whats problem ?
Coordinator
Mar 22, 2013 at 11:50 PM
Hi
It is very hard to solve this issue here, but I can tell you general suggestion:
  1. Make sure your VPN solution work perfectly without BarbaTunnel. Of-course you need a test client outside of enterprise firewall.
  2. Check your client upload network speed with speedtest.net, practically HTTP tunnel will not work if your upload speed is less than 10KilioByte/second (100Kbit/sec).
  3. I test barbatunnel with PPTP & SSTP protocol, so try to check PPTP with windows Authentication first, it should work! When you get success then go more deep with l2tp or radius authentication.
  4. Temporary turn-off all local firewall (windows firewall), when you get success then try to turn them on again.
  5. Make sure port BarbaTunnel port (8080 in your case) does not blocked by enterprise firewall, in worse case you can use port 80.
  6. When you see new connection in Client Side, you should see new connection from server side too, it is very simple get and push HTTP request when downloading a web page and at-least you must see the connection notification, if you don't see you should check your barbatunnel configuration such as server address, port and so on.
  7. Don't forget ti Restart BarbaTunnel every time you change any BarbaTunnel config.
Please share the result to others.
Regards
Mar 23, 2013 at 8:10 PM
vpn blocked in my country , so i used barbatunnel for tunneling and access to vpn
when i used pptp vpn in barbamonitor reprot :
Barba Client Started...
Version: 6.4
FilterDriver: WinpkFilter
Adapter: Local Area Connection
Ready!
New ServerName\HTTP-Retunnel! Server: **********, Protocol: HTTP-Tunnel:80, ConnectionID: 1.
but vpn error 807
your site barba monitor report new vpn-pptp retunneli, . . ..
how connected vpn pptp to barba monitor and use tunnel ?
http://i3.codeplex.com/Download?ProjectName=barbatunnel&DownloadId=327350
Coordinator
Mar 24, 2013 at 7:07 AM
Hi
Please turn on verbose mode and let me know the log.
Regards